Medium, CVSS 6.1PackagistPublished
Wikimedia Parsoid vulnerable to Cross-site Scripting (XSS)
CVE-2021-30458 · GHSA-5pqx-77vf-85rw
- Affected
- Packagist wikimedia/parsoid >= 0.12, < 0.12.2; < 0.11.1
- Fixed in
- 0.11.10.12.2· Vendor fix available
- Issue
- An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. An attacker can send crafted wikitext that Utils/WTUtils.php will transform by using a <meta tag, bypassing sanitization steps, and potentially allowing for XSS.
Recommended action: Upgrade to 0.12.2 or 0.11.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.