Wikimedia Parsoid vulnerable to Cross-site Scripting (XSS)
CVE-2021-30458GHSA-5pqx-77vf-85rw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wikimedia/parsoid 0.12.2, 0.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist wikimedia/parsoid
- Affected
- >= 0.12, < 0.12.2< 0.11.1
- Fixed in
- 0.11.1, 0.12.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5pqx-77vf-85rw lists affected ranges: Packagist wikimedia/parsoid >=0.12 =0 <0.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-30458: 0.98% estimated exploitation activity in the next 30 days; percentile 62.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. An attacker can send crafted wikitext that Utils/WTUtils.php will transform by using a <meta tag, bypassing sanitization steps, and potentially allowing for XSS.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5pqx-77vf-85rw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-30458 Advisory: Wikimedia Parsoid vulnerable to Cross-site Scripting (XSS) IDs: CVE-2021-30458, GHSA-5pqx-77vf-85rw Record: https://patchnext.com/advisories/cve-2021-30458 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wikimedia/parsoid 0.12.2, 0.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist wikimedia/parsoid: affected >= 0.12, < 0.12.2; < 0.11.1; fixed in 0.11.1, 0.12.2 ## Suggested inspection (read-only) - Packagist wikimedia/parsoid: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wikimedia/parsoid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5pqx-77vf-85rw (GitHub-reviewed advisory GHSA-5pqx-77vf-85rw lists affected ranges: Packagist wikimedia/parsoid >=0.12 =0 <0.11.1) Commands are suggestions: review each one before running it.
Loading voting…