Critical, CVSS 9.8PackagistPublished
SQL injection in webbuilders-group silverstripe-kapost-bridge
CVE-2015-10077 · GHSA-32gr-x76g-267w
- Affected
- Packagist webbuilders-group/silverstripe-kapost-bridge < 0.4.0
- Fixed in
- 0.4.0· Vendor fix available
- Issue
- A vulnerability was found in webbuilders-group silverstripe-kapost-bridge 0.3.3. It has been declared as critical. Affected by this vulnerability is the function index/getPreview of the file code/control/KapostService.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 0.4.0 is able to address this issue. The name of the patch is 2e14b0fd0ea35034f90890f364b130fb4645ff35. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220471.
Recommended action: Upgrade to 0.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.