Skip to content

← Actionable
Critical, CVSS 9.8

SQL injection in webbuilders-group silverstripe-kapost-bridge

CVE-2015-10077GHSA-32gr-x76g-267w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (webbuilders-group/silverstripe-kapost-bridge 0.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2015-10077: 0.67% estimated exploitation activity in the next 30 days; percentile 51.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in webbuilders-group silverstripe-kapost-bridge 0.3.3. It has been declared as critical. Affected by this vulnerability is the function index/getPreview of the file code/control/KapostService.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 0.4.0 is able to address this issue. The name of the patch is 2e14b0fd0ea35034f90890f364b130fb4645ff35. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220471.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-32gr-x76g-267w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-10077

Advisory: SQL injection in webbuilders-group silverstripe-kapost-bridge
IDs: CVE-2015-10077, GHSA-32gr-x76g-267w
Record: https://patchnext.com/advisories/cve-2015-10077 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: webbuilders-group/silverstripe-kapost-bridge 0.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist webbuilders-group/silverstripe-kapost-bridge: affected < 0.4.0; fixed in 0.4.0

## Suggested inspection (read-only)
- Packagist webbuilders-group/silverstripe-kapost-bridge: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on webbuilders-group/silverstripe-kapost-bridge.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-32gr-x76g-267w (GitHub-reviewed advisory GHSA-32gr-x76g-267w lists affected ranges: Packagist webbuilders-group/silverstripe-kapost-bridge >=0 <0.4.0)

Commands are suggestions: review each one before running it.

Loading voting…