Skip to content

← Public intelligence

Packagist package

typo3/cms-rte-ckeditor

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.7PackagistPublished

    Cross-Site Scripting in CKEditor4 WordCount Plugin

    GHSA-m8fw-p3cr-6jqc

    Affected
    • Packagist typo3/cms-rte-ckeditor >= 9.5.0, < 9.5.42; >= 10.0.0, < 10.4.39; >= 11.0.0, < 11.5.30
    Fixed in
    9.5.4210.4.3911.5.30· Vendor fix available
    Issue
    CVSS: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C (4.4) Problem The WordCount plugin (npm:ckeditor-wordcount-plugin) for CKEditor4 is vulnerable to cross-site scripting when switching to the source code mode. This plugin is enabled via the Full.yaml configuration present, but is not active in the default configuration. In default scenarios, exploiting this vulnerability requires a valid backend user account. However, if custom plugins are used on the website frontend, which accept and reflect rich-text content submitted by users, no authentication is required. Solution Update to TYPO3 versions 9.5.42 ELTS, 10.4.39 ELTS, 11.5.30 that fix the problem described above. Credits Thanks to Sybille Peters who reported this issue, and to TYPO3 core & security team member Oliver Hader who fixed the issue. References TYPO3-CORE-SA-2023-004 https://github.com/w8tcha/CKEditor-WordCount-Plugin/security/advisories/GHSA-q9w4-w667-qqj4

    Recommended action: Upgrade to 11.5.30, 10.4.39 or 9.5.42 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →