Skip to content

← Actionable
Medium, CVSS 4.7

Cross-Site Scripting in CKEditor4 WordCount Plugin

GHSA-m8fw-p3cr-6jqc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-rte-ckeditor 11.5.30, 10.4.39, 9.5.42), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms-rte-ckeditor

    Affected
    >= 9.5.0, < 9.5.42>= 10.0.0, < 10.4.39>= 11.0.0, < 11.5.30
    Fixed in
    9.5.42, 10.4.39, 11.5.30

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

CVSS: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C (4.4) Problem The WordCount plugin (npm:ckeditor-wordcount-plugin) for CKEditor4 is vulnerable to cross-site scripting when switching to the source code mode. This plugin is enabled via the Full.yaml configuration present, but is not active in the default configuration. In default scenarios, exploiting this vulnerability requires a valid backend user account. However, if custom plugins are used on the website frontend, which accept and reflect rich-text content submitted by users, no authentication is required. Solution Update to TYPO3 versions 9.5.42 ELTS, 10.4.39 ELTS, 11.5.30 that fix the problem described above. Credits Thanks to Sybille Peters who reported this issue, and to TYPO3 core & security team member Oliver Hader who fixed the issue. References TYPO3-CORE-SA-2023-004 https://github.com/w8tcha/CKEditor-WordCount-Plugin/security/advisories/GHSA-q9w4-w667-qqj4

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m8fw-p3cr-6jqc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-m8fw-p3cr-6jqc

Advisory: Cross-Site Scripting in CKEditor4 WordCount Plugin
IDs: GHSA-m8fw-p3cr-6jqc
Record: https://patchnext.com/advisories/ghsa-m8fw-p3cr-6jqc (revision 1, source checked 26 Oct 2026, 14:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms-rte-ckeditor 11.5.30, 10.4.39, 9.5.42. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms-rte-ckeditor: affected >= 9.5.0, < 9.5.42; >= 10.0.0, < 10.4.39; >= 11.0.0, < 11.5.30; fixed in 9.5.42, 10.4.39, 11.5.30

## Suggested inspection (read-only)
- Packagist typo3/cms-rte-ckeditor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms-rte-ckeditor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m8fw-p3cr-6jqc (GitHub-reviewed advisory GHSA-m8fw-p3cr-6jqc lists affected ranges: Packagist typo3/cms-rte-ckeditor >=9.5.0 =10.0.0 =11.0.0 <11.5.30)

Commands are suggestions: review each one before running it.

Loading voting…