Skip to content

← Public intelligence

Packagist package

tribalsystems/zenario

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

10 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5PackagistPublished

    Zenario's Tree Explorer tool from Organizer affected by Cross-site Scripting

    CVE-2024-34460 · GHSA-7qwj-gcjf-828f

    Affected
    • Packagist tribalsystems/zenario < 9.5.60602
    Fixed in
    9.5.60602· Vendor fix available
    Issue
    The Tree Explorer tool from Organizer in Zenario before 9.5.60602 is affected by XSS. (This component was removed in 9.5.60602.)

    Recommended action: Upgrade to 9.5.60602 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8PackagistPublished

    Zenario uses Twig filters insecurely in the Twig Snippet plugin

    CVE-2024-34461 · GHSA-hr2r-w6wc-25pv

    Affected
    • Packagist tribalsystems/zenario < 9.5.60437
    Fixed in
    9.5.60437· Vendor fix available
    Issue
    Zenario before 9.5.60437 uses Twig filters insecurely in the Twig Snippet plugin, and in the site-wide HEAD and BODY elements, enabling code execution by a designer or an administrator.

    Recommended action: Upgrade to 9.5.60437 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8PackagistPublished

    Zenario CMS is vulnerable to Remote Code Execution (RCE).

    CVE-2022-44136 · GHSA-4p38-rc98-cr39

    Affected
    • Packagist tribalsystems/zenario < 9.0.57473
    Fixed in
    9.0.57473· Vendor fix available
    Issue
    Zenario CMS 9.3.57186 is vulnerable to RCE.

    Recommended action: Upgrade to 9.0.57473 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.1PackagistPublished

    Tribal Systems Zenario CMS vulnerable to Cross-site Scripting

    CVE-2020-36608 · GHSA-f92p-f8r2-c87q

    Affected
    • Packagist tribalsystems/zenario < 8.5.51340
    Fixed in
    8.5.51340· Vendor fix available
    Issue
    A vulnerability has been found in Tribal Systems Zenario CMS prior to version 8.5.51340. Affected by this issue is some unknown functionality of the file adminorganizer.js of the component Error Log Module. The manipulation leads to cross site scripting. The attack may be launched remotely. The issue is patched in version 8.5.51340.

    Recommended action: Upgrade to 8.5.51340 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Critical, CVSS 9.1PackagistPublished

    SQL Injection in tribalsystems/zenario

    CVE-2021-26830 · GHSA-w4f3-7f7c-x652

    Affected
    • Packagist tribalsystems/zenario < 8.8.53370
    Fixed in
    8.8.53370· Vendor fix available
    Issue
    SQL Injection in Tribalsystems Zenario CMS 8.8.52729 and prior allows remote attackers to access the database or delete the plugin. This is accomplished via the ID input field of ajax.php in the Pugin library - delete module.

    Recommended action: Upgrade to 8.8.53370 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 4.8PackagistPublished

    Cross-site Scripting in Zenario CMS

    CVE-2021-41952 · GHSA-x8wj-cqmp-3wmm

    Affected
    • Packagist tribalsystems/zenario <= 9.0.54156
    Fixed in
    9.0.55143· Vendor fix available
    Issue
    Zenario CMS 9.0.54156 is vulnerable to Cross Site Scripting (XSS) via upload file to .SVG. An attacker can send malicious files to victims and steals victim's cookie leads to account takeover. The person viewing the image of a contact can be victim of XSS.

    Recommended action: Upgrade to 9.0.55143 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Critical, CVSS 9.8PackagistPublished

    Unrestricted Upload of File with Dangerous Type in Zenario CMS

    CVE-2021-42171 · GHSA-rgg3-3wh7-w935

    Affected
    • Packagist tribalsystems/zenario <= 9.0.54156
    Fixed in
    9.0.55143· Vendor fix available
    Issue
    Zenario CMS 9.0.54156 is vulnerable to File Upload. The web server can be compromised by uploading and executing a web-shell which can run commands, browse system files, browse local resources, attack other servers, and exploit the local vulnerabilities, and so forth.

    Recommended action: Upgrade to 9.0.55143 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. High, CVSS 7.2PackagistPublished

    File upload restriction bypass in Zenario CMS

    CVE-2022-23043 · GHSA-6r86-2jm9-9mh4

    Affected
    • Packagist tribalsystems/zenario < 9.2.55826
    Fixed in
    9.2.55826· Vendor fix available
    Issue
    Zenario CMS 9.2 allows an authenticated admin user to bypass the file upload restriction by creating a new 'File/MIME Types' using the '.phar' extension. Then an attacker can upload a malicious file, intercept the request and change the extension to '.phar' in order to run commands on the server.

    Recommended action: Upgrade to 9.2.55826 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  9. Medium, CVSS 4.9PackagistPublished

    SQL Injection in tribalsystems/zenario

    CVE-2021-27672 · GHSA-gxcm-36qw-j29v

    Affected
    • Packagist tribalsystems/zenario < 8.8.53370
    Fixed in
    8.8.53370· Vendor fix available
    Issue
    SQL Injection in the "adminboxes.ajax.php" component of Tribal Systems Zenario CMS v8.8.52729 allows remote attackers to obtain sesnitive database information by injecting SQL commands into the "cID" parameter when creating a new HTML component.

    Recommended action: Upgrade to 8.8.53370 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  10. Medium, CVSS 4.8PackagistPublished

    reflected XSS in tribalsystems/zenario

    CVE-2021-27673 · GHSA-8hcm-jj4x-4gmr

    Affected
    • Packagist tribalsystems/zenario < 8.8.53370
    Fixed in
    8.8.53370· Vendor fix available
    Issue
    Reflected XSS in the "adminboxes.ajax.php" component of Tribal Systems Zenario CMS v8.8.52729 allows remote attackers to execute arbitrary code by injecting into the "cID" parameter when creating a new HTML component.

    Recommended action: Upgrade to 8.8.53370 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →