File upload restriction bypass in Zenario CMS
CVE-2022-23043GHSA-6r86-2jm9-9mh4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tribalsystems/zenario 9.2.55826), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist tribalsystems/zenario
- Affected
- < 9.2.55826
- Fixed in
- 9.2.55826
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6r86-2jm9-9mh4 lists affected ranges: Packagist tribalsystems/zenario >=0 <9.2.55826
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-23043: 1.46% estimated exploitation activity in the next 30 days; percentile 73.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Zenario CMS 9.2 allows an authenticated admin user to bypass the file upload restriction by creating a new 'File/MIME Types' using the '.phar' extension. Then an attacker can upload a malicious file, intercept the request and change the extension to '.phar' in order to run commands on the server.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6r86-2jm9-9mh4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23043 Advisory: File upload restriction bypass in Zenario CMS IDs: CVE-2022-23043, GHSA-6r86-2jm9-9mh4 Record: https://patchnext.com/advisories/cve-2022-23043 (revision 1, source checked 26 Oct 2026, 14:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tribalsystems/zenario 9.2.55826. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist tribalsystems/zenario: affected < 9.2.55826; fixed in 9.2.55826 ## Suggested inspection (read-only) - Packagist tribalsystems/zenario: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tribalsystems/zenario. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6r86-2jm9-9mh4 (GitHub-reviewed advisory GHSA-6r86-2jm9-9mh4 lists affected ranges: Packagist tribalsystems/zenario >=0 <9.2.55826) Commands are suggestions: review each one before running it.
Loading voting…