Skip to content

← Public intelligence

Packagist package

topthink/framework

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1PackagistPublished

    ThinkPHP Cross-Site Scripting Vulnerability

    CVE-2024-34467 · GHSA-969f-v7jv-pgj3

    Affected
    • Packagist topthink/framework >= 8.0.0, < 8.0.4; >= 6.1.0, < 6.1.5; < 6.0.17
    Fixed in
    6.0.178.0.46.1.5· Vendor fix available
    Issue
    ThinkPHP 8.0.3 allows remote attackers to exploit XSS due to inadequate filtering of function argument values in thinkexception.tpl.

    Recommended action: Upgrade to 8.0.4, 6.1.5 or 6.0.17 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8PackagistPublished

    ThinkPHP Framework vulnerable to remote code execution

    CVE-2022-47945 · GHSA-p4qr-vq2g-22wp

    Affected
    • Packagist topthink/framework < 6.0.14
    Fixed in
    6.0.14· Vendor fix available
    Issue
    ThinkPHP Framework before 6.0.14 allows local file inclusion via the lang parameter when the language pack feature is enabled (langswitchon=true). An unauthenticated and remote attacker can exploit this to execute arbitrary operating system commands, as demonstrated by including pearcmd.php.

    Recommended action: Upgrade to 6.0.14 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8PackagistPublished

    ThinkPHP SQL Injection vulnerability

    CVE-2018-16385 · GHSA-vcm7-88jx-3r39

    Affected
    • Packagist topthink/framework < 5.1.23
    Fixed in
    5.1.23· Vendor fix available
    Issue
    ThinkPHP before 5.1.23 allows SQL Injection via the public/index/index/test/index query string.

    Recommended action: Upgrade to 5.1.23 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Critical, CVSS 9.8PackagistPublished

    Deserialization of Untrusted Data in topthink/framework

    CVE-2021-23592 · GHSA-3fpv-54ff-wqfj

    Affected
    • Packagist topthink/framework < 6.0.12
    Fixed in
    6.0.12· Vendor fix available
    Issue
    The package topthink/framework before version 6.0.12 is vulnerable to Deserialization of Untrusted Data due to insecure unserialize method in the Driver class.

    Recommended action: Upgrade to 6.0.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Critical, CVSS 9.8PackagistPublished

    Deserialization of Untrusted Data in topthink/framework

    CVE-2021-36564 · GHSA-33gc-6cw9-w3g4

    Affected
    • Packagist topthink/framework < 6.0.9
    Fixed in
    6.0.9· Vendor fix available
    Issue
    ThinkPHP v6.0.8 was discovered to contain a deserialization vulnerability via the component vendor\league\flysystem-cached-adapter\src\Storage\Adapter.php.

    Recommended action: Upgrade to 6.0.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →