Deserialization of Untrusted Data in topthink/framework
CVE-2021-23592GHSA-3fpv-54ff-wqfj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (topthink/framework 6.0.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist topthink/framework
- Affected
- < 6.0.12
- Fixed in
- 6.0.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3fpv-54ff-wqfj lists affected ranges: Packagist topthink/framework >=0 <6.0.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-23592: 1.73% estimated exploitation activity in the next 30 days; percentile 77.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The package topthink/framework before version 6.0.12 is vulnerable to Deserialization of Untrusted Data due to insecure unserialize method in the Driver class.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3fpv-54ff-wqfj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23592 Advisory: Deserialization of Untrusted Data in topthink/framework IDs: CVE-2021-23592, GHSA-3fpv-54ff-wqfj Record: https://patchnext.com/advisories/cve-2021-23592 (revision 1, source checked 26 Oct 2026, 14:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: topthink/framework 6.0.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist topthink/framework: affected < 6.0.12; fixed in 6.0.12 ## Suggested inspection (read-only) - Packagist topthink/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on topthink/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3fpv-54ff-wqfj (GitHub-reviewed advisory GHSA-3fpv-54ff-wqfj lists affected ranges: Packagist topthink/framework >=0 <6.0.12) Commands are suggestions: review each one before running it.
Loading voting…