Medium, CVSS 5.4PackagistPublished
Stored XSS in Compare Mode
CVE-2022-38145 · GHSA-66jf-xm2m-7m8r
- Affected
- Packagist silverstripe/versioned-admin >= 1.0.0, < 1.11.1
- Fixed in
- 1.11.1· Vendor fix available
- Issue
- A malicious content author could add a Javascript payload to a page's meta description and get it executed in the versioned history compare view. This vulnerability requires access to the CMS to be deployed. The attacker must then convince a privileged user to access the version history for that page.
Recommended action: Upgrade to 1.11.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.