Stored XSS in Compare Mode
CVE-2022-38145GHSA-66jf-xm2m-7m8r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/versioned-admin 1.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/versioned-admin
- Affected
- >= 1.0.0, < 1.11.1
- Fixed in
- 1.11.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-66jf-xm2m-7m8r lists affected ranges: Packagist silverstripe/versioned-admin >=1.0.0 <1.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-38145: 0.66% estimated exploitation activity in the next 30 days; percentile 51.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A malicious content author could add a Javascript payload to a page's meta description and get it executed in the versioned history compare view. This vulnerability requires access to the CMS to be deployed. The attacker must then convince a privileged user to access the version history for that page.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-66jf-xm2m-7m8r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-38145 Advisory: Stored XSS in Compare Mode IDs: CVE-2022-38145, GHSA-66jf-xm2m-7m8r Record: https://patchnext.com/advisories/cve-2022-38145 (revision 1, source checked 26 Oct 2026, 14:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/versioned-admin 1.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/versioned-admin: affected >= 1.0.0, < 1.11.1; fixed in 1.11.1 ## Suggested inspection (read-only) - Packagist silverstripe/versioned-admin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/versioned-admin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-66jf-xm2m-7m8r (GitHub-reviewed advisory GHSA-66jf-xm2m-7m8r lists affected ranges: Packagist silverstripe/versioned-admin >=1.0.0 <1.11.1) Commands are suggestions: review each one before running it.
Loading voting…