Skip to content

← Public intelligence

Packagist package

setasign/fpdi

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.0PackagistPublished

    FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service

    CVE-2026-45802 · GHSA-2mgw-7q6p-8grg

    Affected
    • Packagist setasign/fpdi < 2.6.7
    Fixed in
    2.6.7· Vendor fix available
    Issue
    Impact This is a significant Denial of Service (DoS) vulnerability. Any application that uses FPDI to process user-supplied PDF files is at risk. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. Patches Fixed as of version 2.6.7 Workarounds No. References No.

    Recommended action: Upgrade to 2.6.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.0PackagistPublished

    FPDI allows Memory Exhaustion (OOM) in PDF Parser which leads to Denial of Service

    CVE-2025-54869 · GHSA-jxhh-4648-vpp3

    Affected
    • Packagist setasign/fpdi < 2.6.4
    Fixed in
    2.6.4· Vendor fix available
    Issue
    Impact This is a significant Denial of Service (DoS) vulnerability. Any application that uses FPDI to process user-supplied PDF files is at risk. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. Patches Fixed as of version 2.6.4 Workarounds No.

    Recommended action: Upgrade to 2.6.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →