FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service
CVE-2026-45802GHSA-2mgw-7q6p-8grg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (setasign/fpdi 2.6.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist setasign/fpdi
- Affected
- < 2.6.7
- Fixed in
- 2.6.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2mgw-7q6p-8grg lists affected ranges: Packagist setasign/fpdi >=0 <2.6.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-45802: 0.26% estimated exploitation activity in the next 30 days; percentile 17.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This is a significant Denial of Service (DoS) vulnerability. Any application that uses FPDI to process user-supplied PDF files is at risk. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. Patches Fixed as of version 2.6.7 Workarounds No. References No.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2mgw-7q6p-8grg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45802 Advisory: FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service IDs: CVE-2026-45802, GHSA-2mgw-7q6p-8grg Record: https://patchnext.com/advisories/cve-2026-45802 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: setasign/fpdi 2.6.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist setasign/fpdi: affected < 2.6.7; fixed in 2.6.7 ## Suggested inspection (read-only) - Packagist setasign/fpdi: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on setasign/fpdi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2mgw-7q6p-8grg (GitHub-reviewed advisory GHSA-2mgw-7q6p-8grg lists affected ranges: Packagist setasign/fpdi >=0 <2.6.7) Commands are suggestions: review each one before running it.
Loading voting…