Critical, CVSS 9.8PackagistPublished
Sabberworm PHP CSS Parser Code injection vulnerability in allSelectors()
CVE-2020-13756 · GHSA-phrq-v4q2-hmq6
- Affected
- Packagist sabberworm/php-css-parser >= 8.3.0, < 8.3.1; >= 8.2.0, < 8.2.1; >= 8.1.0, < 8.1.1; >= 8.0.0, < 8.0.1; >= 7.0.0, < 7.0.4; >= 6.0.0, < 6.0.2; >= 5.2.0, < 5.2.1; >= 5.1.0, < 5.1.3; >= 5.0.0, < 5.0.9; >= 4.0.0, < 4.0.1; >= 3.0.0, < 3.0.1; >= 2.0.0, < 2.0.1; >= 1.0.0, < 1.0.1
- Fixed in
- 8.2.15.2.12.0.15.1.33.0.18.3.18.1.18.0.15.0.94.0.11.0.16.0.27.0.4· Vendor fix available
- Issue
- Sabberworm PHP CSS Parser before 8.3.1 calls eval on uncontrolled data, possibly leading to remote code execution if the function allSelectors() or getSelectorsBySpecificity() is called with input from an attacker.
Recommended action: Upgrade to 8.3.1, 8.2.1, 8.1.1 or 10 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.