Sabberworm PHP CSS Parser Code injection vulnerability in allSelectors()
CVE-2020-13756GHSA-phrq-v4q2-hmq6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sabberworm/php-css-parser 8.3.1, 8.2.1, 8.1.1, 8.0.1, 7.0.4, 6.0.2, 5.2.1, 5.1.3, 5.0.9, 4.0.1, 3.0.1, 2.0.1, 1.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sabberworm/php-css-parser
- Affected
- >= 8.3.0, < 8.3.1>= 8.2.0, < 8.2.1>= 8.1.0, < 8.1.1>= 8.0.0, < 8.0.1>= 7.0.0, < 7.0.4>= 6.0.0, < 6.0.2>= 5.2.0, < 5.2.1>= 5.1.0, < 5.1.3>= 5.0.0, < 5.0.9>= 4.0.0, < 4.0.1>= 3.0.0, < 3.0.1>= 2.0.0, < 2.0.1>= 1.0.0, < 1.0.1
- Fixed in
- 8.2.1, 5.2.1, 2.0.1, 5.1.3, 3.0.1, 8.3.1, 8.1.1, 8.0.1, 5.0.9, 4.0.1, 1.0.1, 6.0.2, 7.0.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-phrq-v4q2-hmq6 lists affected ranges: Packagist sabberworm/php-css-parser >=8.3.0 =8.2.0 =8.1.0 =8.0.0 =7.0.0 =6.0.0 =5.2.0 =5.1.0 =5.0.0 =4.0.0 =3.0.0 =2.0.0 =1.0.0 <1.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-13756: 49.80% estimated exploitation activity in the next 30 days; percentile 98.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Sabberworm PHP CSS Parser before 8.3.1 calls eval on uncontrolled data, possibly leading to remote code execution if the function allSelectors() or getSelectorsBySpecificity() is called with input from an attacker.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-phrq-v4q2-hmq6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-13756 Advisory: Sabberworm PHP CSS Parser Code injection vulnerability in allSelectors() IDs: CVE-2020-13756, GHSA-phrq-v4q2-hmq6 Record: https://patchnext.com/advisories/cve-2020-13756 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sabberworm/php-css-parser 8.3.1, 8.2.1, 8.1.1, 8.0.1, 7.0.4, 6.0.2, 5.2.1, 5.1.3, 5.0.9, 4.0.1, 3.0.1, 2.0.1, 1.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sabberworm/php-css-parser: affected >= 8.3.0, < 8.3.1; >= 8.2.0, < 8.2.1; >= 8.1.0, < 8.1.1; >= 8.0.0, < 8.0.1; >= 7.0.0, < 7.0.4; >= 6.0.0, < 6.0.2; >= 5.2.0, < 5.2.1; >= 5.1.0, < 5.1.3; >= 5.0.0, < 5.0.9; >= 4.0.0, < 4.0.1; >= 3.0.0, < 3.0.1; >= 2.0.0, < 2.0.1; >= 1.0.0, < 1.0.1; fixed in 8.2.1, 5.2.1, 2.0.1, 5.1.3, 3.0.1, 8.3.1, 8.1.1, 8.0.1, 5.0.9, 4.0.1, 1.0.1, 6.0.2, 7.0.4 ## Suggested inspection (read-only) - Packagist sabberworm/php-css-parser: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sabberworm/php-css-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-phrq-v4q2-hmq6 (GitHub-reviewed advisory GHSA-phrq-v4q2-hmq6 lists affected ranges: Packagist sabberworm/php-css-parser >=8.3.0 =8.2.0 =8.1.0 =8.0.0 =7.0.0 =6.0.0 =5.2.0 =5.1.0 =5.0.0 =4.0.0 =3.0.0 =2.0.0 =1.0.0 <1.0.1) Commands are suggestions: review each one before running it.
Loading voting…