Medium, CVSS 6.1PackagistPublished
Roots Soil plugin vulnerable to Cross-site Scripting
CVE-2022-4524 · GHSA-jw6x-4h8h-569x
- Affected
- Packagist roots/soil < 4.1.0
- Fixed in
- 4.1.0· Vendor fix available
- Issue
- A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.1.0. Affected is the function languageattributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.1 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.
Recommended action: Upgrade to 4.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.