Roots Soil plugin vulnerable to Cross-site Scripting
CVE-2022-4524GHSA-jw6x-4h8h-569x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (roots/soil 4.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist roots/soil
- Affected
- < 4.1.0
- Fixed in
- 4.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jw6x-4h8h-569x lists affected ranges: Packagist roots/soil >=0 <4.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-4524: 0.59% estimated exploitation activity in the next 30 days; percentile 48.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.1.0. Affected is the function languageattributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.1 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jw6x-4h8h-569x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-4524 Advisory: Roots Soil plugin vulnerable to Cross-site Scripting IDs: CVE-2022-4524, GHSA-jw6x-4h8h-569x Record: https://patchnext.com/advisories/cve-2022-4524 (revision 1, source checked 26 Oct 2026, 13:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: roots/soil 4.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist roots/soil: affected < 4.1.0; fixed in 4.1.0 ## Suggested inspection (read-only) - Packagist roots/soil: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on roots/soil. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jw6x-4h8h-569x (GitHub-reviewed advisory GHSA-jw6x-4h8h-569x lists affected ranges: Packagist roots/soil >=0 <4.1.0) Commands are suggestions: review each one before running it.
Loading voting…