Skip to content

← Public intelligence

Packagist package

robrichards/xmlseclibs

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.2PackagistPublished

    xmlseclibs: Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption

    CVE-2026-32313 · GHSA-4v26-v6cg-g6f9

    Affected
    • Packagist robrichards/xmlseclibs < 3.1.5
    Fixed in
    3.1.5· Vendor fix available
    Issue
    XML nodes encrypted with either aes-128-gcm, aes-192-gcm, or aes-256-gcm lack validation of the authentication tag length. An attacker can use this to brute-force an authentication tag, recover the GHASH key, and decrypt the encrypted nodes. It also allows to forge arbitrary ciphertexts without knowing the encryption key. Details When decrypting with either aes-128-gcm, aes-192-gcm, or aes-256-gcm here, the $authTag is set from a substr(), but never has its length validated (it should be validated with something like strlen($authTag) == self::AUTHTAGLENGTH). For that reason, a shorter than expected data blob will allow for the $authTag to have as short a tag as only one byte (see PHP's documentation%20has%20been%20called.%20Otherwise%20the%20decryption%20may%20succeed%20if%20the%20given%20tag%20only%20matches%20the%20start%20of%20the%20proper%20tag.)). See this example: With a legit ciphertext in hand, this is enough to recover the GHASH key. With that key, any authenticated…

    Recommended action: Upgrade to 3.1.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.0PackagistPublished

    robrichards/xmlseclibs has an Libxml2 Canonicalization error which can bypass Digest/Signature validation

    CVE-2025-66578 · GHSA-c4cc-x928-vjw9

    Affected
    • Packagist robrichards/xmlseclibs <= 3.1.3
    Fixed in
    3.1.4· Vendor fix available
    Issue
    An authentication bypass vulnerability exists due to a flaw in the libxml2 canonicalization process, which is used by xmlseclibs during document transformation. This weakness allows an attacker to generate a valid signature once and reuse it indefinitely. In practice, a signature created during a previous interaction - or through a misconfigured authentication flow - can be replayed to bypass authentication checks. Details When libxml2’s canonicalization is invoked on an invalid XML input, it may return an empty string rather than a canonicalized node. xmlseclibs then proceeds to compute the DigestValue over this empty string, treating it as if canonicalization succeeded. https://github.com/robrichards/xmlseclibs/blob/f4131320c6dcd460f1b0c67f16f8bf24ce4b5c3e/src/XMLSecurityDSig.php#L296 Impact Digest bypass: By crafting input that causes canonicalization to yield an empty string, the attacker can manipulate validation to pass incorrectly. Signature replay on empty canonical…

    Recommended action: Upgrade to 3.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5PackagistPublished

    robrichards/xmlseclibs XPath injection

    GHSA-2g98-f9jv-w8c5

    Affected
    • Packagist robrichards/xmlseclibs >= 1.0.0, < 3.0.2
    Fixed in
    3.0.2· Vendor fix available
    Issue
    A vulnerability has been identified in the robrichards/xmlseclibs library, specifically related to XPath injection. The issue arises from inadequate filtering of user input before it is incorporated into XPath expressions.

    Recommended action: Upgrade to 3.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 8.8PackagistPublished

    Signature validation bypass in XmlSecLibs

    CVE-2019-3465 · GHSA-pqm6-cgwr-x6pf

    Affected
    • Packagist robrichards/xmlseclibs >= 3.0.0, < 3.0.4; >= 1.0.0, < 2.1.1
    Fixed in
    3.0.42.1.1· Vendor fix available
    Issue
    Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

    Recommended action: Upgrade to 3.0.4 or 2.1.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →