robrichards/xmlseclibs has an Libxml2 Canonicalization error which can bypass Digest/Signature validation
CVE-2025-66578GHSA-c4cc-x928-vjw9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (robrichards/xmlseclibs 3.1.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist robrichards/xmlseclibs
- Affected
- <= 3.1.3
- Fixed in
- 3.1.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c4cc-x928-vjw9 lists affected ranges: Packagist robrichards/xmlseclibs >=0 <=3.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.0 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L
- EPSS
- CVE-2025-66578: 0.24% estimated exploitation activity in the next 30 days; percentile 15.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authentication bypass vulnerability exists due to a flaw in the libxml2 canonicalization process, which is used by xmlseclibs during document transformation. This weakness allows an attacker to generate a valid signature once and reuse it indefinitely. In practice, a signature created during a previous interaction - or through a misconfigured authentication flow - can be replayed to bypass authentication checks. Details When libxml2’s canonicalization is invoked on an invalid XML input, it may return an empty string rather than a canonicalized node. xmlseclibs then proceeds to compute the DigestValue over this empty string, treating it as if canonicalization succeeded. https://github.com/robrichards/xmlseclibs/blob/f4131320c6dcd460f1b0c67f16f8bf24ce4b5c3e/src/XMLSecurityDSig.php#L296 Impact Digest bypass: By crafting input that causes canonicalization to yield an empty string, the attacker can manipulate validation to pass incorrectly. Signature replay on empty canonical…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c4cc-x928-vjw9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66578 Advisory: robrichards/xmlseclibs has an Libxml2 Canonicalization error which can bypass Digest/Signature validation IDs: CVE-2025-66578, GHSA-c4cc-x928-vjw9 Record: https://patchnext.com/advisories/cve-2025-66578 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: robrichards/xmlseclibs 3.1.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist robrichards/xmlseclibs: affected <= 3.1.3; fixed in 3.1.4 ## Suggested inspection (read-only) - Packagist robrichards/xmlseclibs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on robrichards/xmlseclibs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c4cc-x928-vjw9 (GitHub-reviewed advisory GHSA-c4cc-x928-vjw9 lists affected ranges: Packagist robrichards/xmlseclibs >=0 <=3.1.3) Commands are suggestions: review each one before running it.
Loading voting…