Skip to content

← Public intelligence

Packagist package

psy/psysh

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.7PackagistPublished

    PsySH has Local Privilege Escalation via CWD .psysh.php auto-load

    CVE-2026-25129 · GHSA-4486-gxhx-5mg7

    Affected
    • Packagist psy/psysh >= 0.12.0, <= 0.12.18; <= 0.11.22
    Fixed in
    0.11.230.12.19· Vendor fix available
    Issue
    PsySH automatically loads and executes a .psysh.php file from the Current Working Directory (CWD) on startup. If an attacker can write to a directory that a victim later uses as their CWD when launching PsySH, the attacker can trigger arbitrary code execution in the victim's context. When the victim runs PsySH with elevated privileges (e.g., root), this results in local privilege escalation. Details PsySH supports per-directory configuration via a .psysh.php file located in the process CWD. This file is executed implicitly when PsySH starts, without requiring explicit opt-in and without validating that the file and directory are safe (e.g., owned by the current user and not group/world-writable). This enables a CWD poisoning scenario: a low-privileged user can plant a malicious .psysh.php in any directory they can write to, then wait for a higher-privileged user to start PsySH while their shell is in that directory. PoC 1. As a low-privileged user, create a malicious…

    Recommended action: Upgrade to 0.12.19 or 0.11.23 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →