PsySH has Local Privilege Escalation via CWD .psysh.php auto-load
CVE-2026-25129GHSA-4486-gxhx-5mg7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (psy/psysh 0.12.19, 0.11.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist psy/psysh
- Affected
- >= 0.12.0, <= 0.12.18<= 0.11.22
- Fixed in
- 0.11.23, 0.12.19
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4486-gxhx-5mg7 lists affected ranges: Packagist psy/psysh >=0.12.0 =0 <=0.11.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.7 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-25129: 0.32% estimated exploitation activity in the next 30 days; percentile 25.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary PsySH automatically loads and executes a .psysh.php file from the Current Working Directory (CWD) on startup. If an attacker can write to a directory that a victim later uses as their CWD when launching PsySH, the attacker can trigger arbitrary code execution in the victim's context. When the victim runs PsySH with elevated privileges (e.g., root), this results in local privilege escalation. Details PsySH supports per-directory configuration via a .psysh.php file located in the process CWD. This file is executed implicitly when PsySH starts, without requiring explicit opt-in and without validating that the file and directory are safe (e.g., owned by the current user and not group/world-writable). This enables a CWD poisoning scenario: a low-privileged user can plant a malicious .psysh.php in any directory they can write to, then wait for a higher-privileged user to start PsySH while their shell is in that directory. PoC 1. As a low-privileged user, create a malicious…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4486-gxhx-5mg7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25129 Advisory: PsySH has Local Privilege Escalation via CWD .psysh.php auto-load IDs: CVE-2026-25129, GHSA-4486-gxhx-5mg7 Record: https://patchnext.com/advisories/cve-2026-25129 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: psy/psysh 0.12.19, 0.11.23. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist psy/psysh: affected >= 0.12.0, <= 0.12.18; <= 0.11.22; fixed in 0.11.23, 0.12.19 ## Suggested inspection (read-only) - Packagist psy/psysh: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on psy/psysh. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4486-gxhx-5mg7 (GitHub-reviewed advisory GHSA-4486-gxhx-5mg7 lists affected ranges: Packagist psy/psysh >=0.12.0 =0 <=0.11.22) Commands are suggestions: review each one before running it.
Loading voting…