Skip to content

← Public intelligence

Packagist package

prestashop/productcomments

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3PackagistPublished

    PrestaShop Product Comments Cross-site Scripting vulnerability

    CVE-2022-35933 · GHSA-prrh-qvhf-x788

    Affected
    • Packagist prestashop/productcomments < 5.0.2
    Fixed in
    5.0.2· Vendor fix available
    Issue
    Impact An attacker could steal an admin's cookie Patches The issue is fixed in 5.0.2 References Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

    Recommended action: Upgrade to 5.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.2PackagistPublished

    Blind SQL injection in PrestaShop productcomments module

    CVE-2020-26248 · GHSA-5v44-7647-xfw9

    Affected
    • Packagist prestashop/productcomments >= 4.0.0, < 4.2.1
    Fixed in
    4.2.1· Vendor fix available
    Issue
    Impact An attacker can use a Blind SQL injection to retrieve data or stop the MySQL service. Patches The problem is fixed in 4.2.1

    Recommended action: Upgrade to 4.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.7PackagistPublished

    Reflected XSS with parameters in PostComment

    CVE-2020-26225 · GHSA-58w4-w77w-qv3w

    Affected
    • Packagist prestashop/productcomments >= 4.0.0, < 4.2.0
    Fixed in
    4.2.0· Vendor fix available
    Issue
    Impact An attacker could inject malicious web code into the users' web browsers by creating a malicious link. Patches The problem is fixed in 4.2.0 References Cross-site Scripting (XSS) - Reflected (CWE-79)

    Recommended action: Upgrade to 4.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →