Reflected XSS with parameters in PostComment
CVE-2020-26225GHSA-58w4-w77w-qv3w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (prestashop/productcomments 4.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist prestashop/productcomments
- Affected
- >= 4.0.0, < 4.2.0
- Fixed in
- 4.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-58w4-w77w-qv3w lists affected ranges: Packagist prestashop/productcomments >=4.0.0 <4.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2020-26225: 0.89% estimated exploitation activity in the next 30 days; percentile 59.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker could inject malicious web code into the users' web browsers by creating a malicious link. Patches The problem is fixed in 4.2.0 References Cross-site Scripting (XSS) - Reflected (CWE-79)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-58w4-w77w-qv3w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-26225 Advisory: Reflected XSS with parameters in PostComment IDs: CVE-2020-26225, GHSA-58w4-w77w-qv3w Record: https://patchnext.com/advisories/cve-2020-26225 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: prestashop/productcomments 4.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist prestashop/productcomments: affected >= 4.0.0, < 4.2.0; fixed in 4.2.0 ## Suggested inspection (read-only) - Packagist prestashop/productcomments: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on prestashop/productcomments. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-58w4-w77w-qv3w (GitHub-reviewed advisory GHSA-58w4-w77w-qv3w lists affected ranges: Packagist prestashop/productcomments >=4.0.0 <4.2.0) Commands are suggestions: review each one before running it.
Loading voting…