High, CVSS 8.7PackagistPublished
Pimcore includes vulnerable PHPOffice/PhpSpreadsheet
GHSA-hq76-662x-7mw4
- Affected
- Packagist pimcore/data-importer < 1.8.9; >= 1.9.0, < 1.9.3
- Fixed in
- 1.8.91.9.3· Vendor fix available
- Issue
- Pimcore 10.6.x and Enterprise 10.6.x versions currently depend on PHPOffice/PhpSpreadsheet version 1.x, which has recently been identified with a security vulnerability (CVE-2024-45048). To mitigate this issue, it is recommended to update to the latest version 2.2.2. For more details, please refer to the official advisory: GHSA-ghg6-32f9-2jp7.
Recommended action: Upgrade to 1.9.3 or 1.8.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.