Skip to content

← Actionable
High, CVSS 8.7

Pimcore includes vulnerable PHPOffice/PhpSpreadsheet

GHSA-hq76-662x-7mw4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/data-importer 1.9.3, 1.8.9; pimcore/pimcore 11.1.6.11, 10.6.9.12; pimcore/admin-ui-classic-bundle 1.5.4, 1.4.7, 1.3.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-hq76-662x-7mw4 lists affected ranges: Packagist pimcore/data-importer >=0 =1.9.0 =0 =1.4.0 =1.5.0 =10.6.9.0 =11.1.0.0 <11.1.6.11

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Pimcore 10.6.x and Enterprise 10.6.x versions currently depend on PHPOffice/PhpSpreadsheet version 1.x, which has recently been identified with a security vulnerability (CVE-2024-45048). To mitigate this issue, it is recommended to update to the latest version 2.2.2. For more details, please refer to the official advisory: GHSA-ghg6-32f9-2jp7.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hq76-662x-7mw4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-hq76-662x-7mw4

Advisory: Pimcore includes vulnerable PHPOffice/PhpSpreadsheet
IDs: GHSA-hq76-662x-7mw4
Record: https://patchnext.com/advisories/ghsa-hq76-662x-7mw4 (revision 1, source checked 26 Oct 2026, 14:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pimcore/data-importer 1.9.3, 1.8.9; pimcore/pimcore 11.1.6.11, 10.6.9.12; pimcore/admin-ui-classic-bundle 1.5.4, 1.4.7, 1.3.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pimcore/data-importer: affected < 1.8.9; >= 1.9.0, < 1.9.3; fixed in 1.8.9, 1.9.3
- Packagist pimcore/pimcore: affected >= 10.6.9.0, < 10.6.9.12; >= 11.1.0.0, < 11.1.6.11; fixed in 10.6.9.12, 11.1.6.11
- Packagist pimcore/admin-ui-classic-bundle: affected < 1.3.11; >= 1.4.0, < 1.4.7; >= 1.5.0, < 1.5.4; fixed in 1.3.11, 1.5.4, 1.4.7

## Suggested inspection (read-only)
- Packagist pimcore/data-importer: check the installed version with your package manager.
- Packagist pimcore/pimcore: check the installed version with your package manager.
- Packagist pimcore/admin-ui-classic-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pimcore/data-importer, pimcore/pimcore, pimcore/admin-ui-classic-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hq76-662x-7mw4 (GitHub-reviewed advisory GHSA-hq76-662x-7mw4 lists affected ranges: Packagist pimcore/data-importer >=0 =1.9.0 =0 =1.4.0 =1.5.0 =10.6.9.0 =11.1.0.0 <11.1.6.11)

Commands are suggestions: review each one before running it.

Loading voting…