Skip to content

← Public intelligence

Packagist package

paragonie/sodium_compat

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.5PackagistAmendedPublished

    libsodium has Incomplete List of Disallowed Inputs

    CVE-2025-69277 · GHSA-mrfv-m5wm-5w6w

    Affected
    • Packagist paragonie/sodium_compat >= 2, < 2.5.0; < 1.24.0
    Fixed in
    1.24.02.5.0· Vendor fix available
    Issue
    libsodium before ad3004e, in atypical use cases involving certain custom cryptography or untrusted data to cryptocoreed25519isvalidpoint, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group. This advisoory lists packages in the GitHub Advisory Database's supported ecosystems that are affected by this vulnerability due to a vulnerable dependency.

    Recommended action: Upgrade to 2.5.0 or 1.24.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →