libsodium has Incomplete List of Disallowed Inputs
CVE-2025-69277GHSA-mrfv-m5wm-5w6w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (hdwallet 3.6.1; paragonie/sodium_compat 2.5.0, 1.24.0; pynacl 1.6.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI hdwallet
- Affected
- < 3.6.1
- Fixed in
- 3.6.1
Packagist paragonie/sodium_compat
- Affected
- >= 2, < 2.5.0< 1.24.0
- Fixed in
- 1.24.0, 2.5.0
PyPI pynacl
- Affected
- < 1.6.2
- Fixed in
- 1.6.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mrfv-m5wm-5w6w lists affected ranges: Packagist paragonie/sodium_compat >=2 =0 =0 =0 <3.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mrfv-m5wm-5w6w lists affected ranges: Packagist paragonie/sodium_compat >=2 =0 =0 =0 <3.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.5 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2025-69277: 0.18% estimated exploitation activity in the next 30 days; percentile 7.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
libsodium before ad3004e, in atypical use cases involving certain custom cryptography or untrusted data to cryptocoreed25519isvalidpoint, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group. This advisoory lists packages in the GitHub Advisory Database's supported ecosystems that are affected by this vulnerability due to a vulnerable dependency.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mrfv-m5wm-5w6w
- Revision 1 · created ·
Published from osv record GHSA-mrfv-m5wm-5w6w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-69277 Advisory: libsodium has Incomplete List of Disallowed Inputs IDs: CVE-2025-69277, GHSA-mrfv-m5wm-5w6w Record: https://patchnext.com/advisories/cve-2025-69277 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: hdwallet 3.6.1; paragonie/sodium_compat 2.5.0, 1.24.0; pynacl 1.6.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI hdwallet: affected < 3.6.1; fixed in 3.6.1 - Packagist paragonie/sodium_compat: affected >= 2, < 2.5.0; < 1.24.0; fixed in 1.24.0, 2.5.0 - PyPI pynacl: affected < 1.6.2; fixed in 1.6.2 ## Suggested inspection (read-only) - `python -m pip show hdwallet`: prints the installed version. Run with the environment that serves production active. - Packagist paragonie/sodium_compat: check the installed version with your package manager. - `python -m pip show pynacl`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on hdwallet, paragonie/sodium_compat, pynacl. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mrfv-m5wm-5w6w (OSV record GHSA-mrfv-m5wm-5w6w lists affected ranges: Packagist paragonie/sodium_compat >=2 =0 =0 =0 <3.6.1 (fixed)) - Verified: https://github.com/advisories/GHSA-mrfv-m5wm-5w6w (GitHub-reviewed advisory GHSA-mrfv-m5wm-5w6w lists affected ranges: Packagist paragonie/sodium_compat >=2 =0 =0 =0 <3.6.1) Commands are suggestions: review each one before running it.
Loading voting…