Skip to content

← Public intelligence

Packagist package

packbackbooks/lti-1-3-php-library

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PackagistPublished

    LTI 1.3 Tool Library's Nonce Claim Value not validated against nonce value sent in Authentication Request before v5.0

    CVE-2022-31158 · GHSA-5p73-qg2v-383h

    Affected
    • Packagist packbackbooks/lti-1-3-php-library < 5.0
    Fixed in
    5.0· Vendor fix available
    Issue
    Impact Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Patches Users should upgrade to version 5.0 immediately Workarounds None.

    Recommended action: Upgrade to 5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5PackagistPublished

    LTI 1.3 Tool Library's function used to generate random nonces not sufficiently cryptographically complex before v5.0

    CVE-2022-31157 · GHSA-768m-5w34-2xf5

    Affected
    • Packagist packbackbooks/lti-1-3-php-library < 5.0
    Fixed in
    5.0· Vendor fix available
    Issue
    Impact The function used to generate random nonces was not sufficiently cryptographically complex. As a result values may be predictable and tokens may be forgable. Patches Users should upgrade to version 5.0 immediately Workarounds None.

    Recommended action: Upgrade to 5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →