LTI 1.3 Tool Library's Nonce Claim Value not validated against nonce value sent in Authentication Request before v5.0
CVE-2022-31158GHSA-5p73-qg2v-383h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (packbackbooks/lti-1-3-php-library 5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist packbackbooks/lti-1-3-php-library
- Affected
- < 5.0
- Fixed in
- 5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5p73-qg2v-383h lists affected ranges: Packagist packbackbooks/lti-1-3-php-library >=0 <5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2022-31158: 0.86% estimated exploitation activity in the next 30 days; percentile 58.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Patches Users should upgrade to version 5.0 immediately Workarounds None.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5p73-qg2v-383h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31158 Advisory: LTI 1.3 Tool Library's Nonce Claim Value not validated against nonce value sent in Authentication Request before v5.0 IDs: CVE-2022-31158, GHSA-5p73-qg2v-383h Record: https://patchnext.com/advisories/cve-2022-31158 (revision 1, source checked 26 Oct 2026, 14:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: packbackbooks/lti-1-3-php-library 5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist packbackbooks/lti-1-3-php-library: affected < 5.0; fixed in 5.0 ## Suggested inspection (read-only) - Packagist packbackbooks/lti-1-3-php-library: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on packbackbooks/lti-1-3-php-library. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5p73-qg2v-383h (GitHub-reviewed advisory GHSA-5p73-qg2v-383h lists affected ranges: Packagist packbackbooks/lti-1-3-php-library >=0 <5.0) Commands are suggestions: review each one before running it.
Loading voting…