Medium, CVSS 5.4PackagistPublished
Neos CMS Cross Site Scripting vulnerability
CVE-2023-37611 · GHSA-6qjf-7g3j-qx25
- Affected
- Packagist neos/media-browser < 7.3.19; >= 8.0.0, < 8.0.16; >= 8.1.0, < 8.1.11; >= 8.2.0, < 8.2.11; >= 8.3.0, < 8.3.9
- Fixed in
- 8.0.167.3.198.1.118.2.118.3.9· Vendor fix available
- Issue
- Cross Site Scripting (XSS) vulnerability in Neos CMS 8.3.3 allows a remote authenticated attacker to execute arbitrary code via a crafted SVG file uploaded to the neos/management/media component. To make use of this attack vector, the attacker must either be able to upload a maliciously crafted file or coerce someone with the needed access to upload said file to Neos. Even if such a file is uploaded and subsequently delivered, it is possible to use CSP to protect against attacks being executed from such a file.
Recommended action: Upgrade to 8.3.9, 8.2.11, 8.1.11 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.