Neos CMS Cross Site Scripting vulnerability
CVE-2023-37611GHSA-6qjf-7g3j-qx25
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (neos/media-browser 8.3.9, 8.2.11, 8.1.11, 8.0.16, 7.3.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist neos/media-browser
- Affected
- < 7.3.19>= 8.0.0, < 8.0.16>= 8.1.0, < 8.1.11>= 8.2.0, < 8.2.11>= 8.3.0, < 8.3.9
- Fixed in
- 8.0.16, 7.3.19, 8.1.11, 8.2.11, 8.3.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6qjf-7g3j-qx25 lists affected ranges: Packagist neos/media-browser >=0 =8.0.0 =8.1.0 =8.2.0 =8.3.0 <8.3.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-37611: 0.71% estimated exploitation activity in the next 30 days; percentile 53.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross Site Scripting (XSS) vulnerability in Neos CMS 8.3.3 allows a remote authenticated attacker to execute arbitrary code via a crafted SVG file uploaded to the neos/management/media component. To make use of this attack vector, the attacker must either be able to upload a maliciously crafted file or coerce someone with the needed access to upload said file to Neos. Even if such a file is uploaded and subsequently delivered, it is possible to use CSP to protect against attacks being executed from such a file.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6qjf-7g3j-qx25
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-37611 Advisory: Neos CMS Cross Site Scripting vulnerability IDs: CVE-2023-37611, GHSA-6qjf-7g3j-qx25 Record: https://patchnext.com/advisories/cve-2023-37611 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: neos/media-browser 8.3.9, 8.2.11, 8.1.11, 8.0.16, 7.3.19. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist neos/media-browser: affected < 7.3.19; >= 8.0.0, < 8.0.16; >= 8.1.0, < 8.1.11; >= 8.2.0, < 8.2.11; >= 8.3.0, < 8.3.9; fixed in 8.0.16, 7.3.19, 8.1.11, 8.2.11, 8.3.9 ## Suggested inspection (read-only) - Packagist neos/media-browser: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on neos/media-browser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6qjf-7g3j-qx25 (GitHub-reviewed advisory GHSA-6qjf-7g3j-qx25 lists affected ranges: Packagist neos/media-browser >=0 =8.0.0 =8.1.0 =8.2.0 =8.3.0 <8.3.9) Commands are suggestions: review each one before running it.
Loading voting…