Skip to content

← Public intelligence

Packagist package

mediawiki/cargo

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9PackagistPublished

    Cargo Mediawiki Extension vulnerable to Cross-site Scripting

    CVE-2025-62671 · GHSA-gr6v-3pmp-996p

    Affected
    • Packagist mediawiki/cargo < 3.8.3
    Fixed in
    3.8.3· Vendor fix available
    Issue
    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in The Wikimedia Foundation Mediawiki - Cargo Extension allows Stored XSS. This issue affects Mediawiki - Cargo Extension befor 3.8.3.

    Recommended action: Upgrade to 3.8.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.9PackagistPublished

    Mediawiki Cargo extension vulnerable to Cross-site Scripting

    CVE-2024-47847 · GHSA-jqvm-9xm2-gc38

    Affected
    • Packagist mediawiki/cargo < 3.6.1
    Fixed in
    3.6.1· Vendor fix available
    Issue
    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in The Wikimedia Foundation Mediawiki - Cargo allows Cross-Site Scripting (XSS).This issue affects Mediawiki - Cargo: from 3.6.X before 3.6.1.

    Recommended action: Upgrade to 3.6.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.1PackagistPublished

    MediaWiki Cargo Extension Cross-site Scripting vulnerability

    CVE-2024-23173 · GHSA-rhpm-63w5-79rg

    Affected
    • Packagist mediawiki/cargo < 1.35.14; >= 1.36.0, < 1.39.6; >= 1.40.0, < 1.40.2
    Fixed in
    1.40.21.35.141.39.6· Vendor fix available
    Issue
    An issue was discovered in the Cargo extension in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. The Special:Drilldown page allows XSS via artist, album, and position parameters because of applied filter values in drilldown/CargoAppliedFilter.php.

    Recommended action: Upgrade to 1.40.2, 1.39.6 or 1.35.14 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →