MediaWiki Cargo Extension Cross-site Scripting vulnerability
CVE-2024-23173GHSA-rhpm-63w5-79rg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mediawiki/cargo 1.40.2, 1.39.6, 1.35.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mediawiki/cargo
- Affected
- < 1.35.14>= 1.36.0, < 1.39.6>= 1.40.0, < 1.40.2
- Fixed in
- 1.40.2, 1.35.14, 1.39.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rhpm-63w5-79rg lists affected ranges: Packagist mediawiki/cargo >=0 =1.36.0 =1.40.0 <1.40.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-23173: 0.42% estimated exploitation activity in the next 30 days; percentile 36.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in the Cargo extension in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. The Special:Drilldown page allows XSS via artist, album, and position parameters because of applied filter values in drilldown/CargoAppliedFilter.php.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rhpm-63w5-79rg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-23173 Advisory: MediaWiki Cargo Extension Cross-site Scripting vulnerability IDs: CVE-2024-23173, GHSA-rhpm-63w5-79rg Record: https://patchnext.com/advisories/cve-2024-23173 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mediawiki/cargo 1.40.2, 1.39.6, 1.35.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mediawiki/cargo: affected < 1.35.14; >= 1.36.0, < 1.39.6; >= 1.40.0, < 1.40.2; fixed in 1.40.2, 1.35.14, 1.39.6 ## Suggested inspection (read-only) - Packagist mediawiki/cargo: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mediawiki/cargo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rhpm-63w5-79rg (GitHub-reviewed advisory GHSA-rhpm-63w5-79rg lists affected ranges: Packagist mediawiki/cargo >=0 =1.36.0 =1.40.0 <1.40.2) Commands are suggestions: review each one before running it.
Loading voting…