Skip to content

← Public intelligence

Packagist package

mautic/core-lib

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.1PackagistPublished

    Mautic has insufficient authentication in upgrade flow

    CVE-2022-25770 · GHSA-qf6m-6m4g-rmrc

    Affected
    • Packagist mautic/core-lib >= 1.0.0-beta3, < 4.4.13; >= 5.0.0-alpha, < 5.1.1
    Fixed in
    4.4.135.1.1· Vendor fix available
    Issue
    Impact Mautic allows you to update the application via an upgrade script. The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation. This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable Patches Please upgrade to 4.4.1 or 5.1.1 or later. Workarounds None. For more information If you have any questions or comments about this advisory: Email us at security@mautic.org

    Recommended action: Upgrade to 5.1.1 or 4.4.13 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.1PackagistPublished

    Mautic has an XSS in contact tracking and page hits report

    CVE-2021-27917 · GHSA-xpc5-rr39-v8v2

    Affected
    • Packagist mautic/core-lib >= 1.0.0-beta4, < 4.4.13; >= 5.0.0-alpha, < 5.1.1
    Fixed in
    4.4.135.1.1· Vendor fix available
    Issue
    Prior to this patch, a stored XSS vulnerability existed in the contact tracking and page hits report. Patches Please update to 4.4.13 or 5.1.1 or later. Workarounds None References https://owasp.org/www-project-top-ten/2017/A72017-Cross-SiteScripting(XSS) https://owasp.org/www-project-web-security-testing-guide/latest/4-WebApplicationSecurityTesting/07-InputValidationTesting/02-TestingforStoredCrossSiteScripting If you have any questions or comments about this advisory: Email us at security@mautic.org

    Recommended action: Upgrade to 5.1.1 or 4.4.13 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.1PackagistPublished

    Mautic vulnerable to XSS in contact/company tracking (no authentication)

    CVE-2024-47050 · GHSA-73gr-32wg-qhh7

    Affected
    • Packagist mautic/core-lib >= 2.6.0, < 4.4.13; >= 5.0.0-alpha, < 5.1.1
    Fixed in
    4.4.135.1.1· Vendor fix available
    Issue
    Prior to this patch being applied, Mautic's tracking was vulnerable to Cross-Site Scripting through the Page URL variable. Patches Please update to 4.4.13 or 5.1.1 or later. Workarounds None References https://owasp.org/www-project-top-ten/2017/A72017-Cross-SiteScripting(XSS) https://owasp.org/www-project-web-security-testing-guide/latest/4-WebApplicationSecurityTesting/07-InputValidationTesting/02-TestingforStoredCrossSiteScripting If you have any questions or comments about this advisory: Email us at security@mautic.org

    Recommended action: Upgrade to 5.1.1 or 4.4.13 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 5.1PackagistPublished

    Mautic vulnerable to Cross-site Scripting (XSS) - stored (edit form HTML field)

    CVE-2024-47058 · GHSA-xv68-rrmw-9xwf

    Affected
    • Packagist mautic/core-lib >= 5.0.0-alpha, < 5.1.1; >= 1.0.0-beta, < 4.4.13
    Fixed in
    4.4.135.1.1· Vendor fix available
    Issue
    Impact With access to edit a Mautic form, the attacker can add Cross-Site Scripting stored in the html filed. This could be used to steal sensitive information from the user's current session. Patches Upgrade to 4.4.13 or 5.1.1 or later. Workarounds None References - https://owasp.org/www-project-top-ten/2017/A72017-Cross-SiteScripting(XSS) - https://owasp.org/www-project-web-security-testing-guide/latest/4-WebApplicationSecurityTesting/07-InputValidationTesting/02-TestingforStoredCrossSiteScripting If you have any questions or comments about this advisory: Email us at security@mautic.org

    Recommended action: Upgrade to 5.1.1 or 4.4.13 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 8.3PackagistPublished

    Mautic vulnerable to Improper Access Control in UI upgrade process

    CVE-2022-25768 · GHSA-x3jx-5w6m-q2fc

    Affected
    • Packagist mautic/core-lib >= 1.1.3, < 4.4.13; >= 5.0.0-alpha, < 5.1.1
    Fixed in
    4.4.135.1.1· Vendor fix available
    Issue
    Impact The logic in place to facilitate the update process via the user interface lacks access control to verify if permission exists to perform the tasks. Prior to this patch being applied it might be possible for an attacker to access the Mautic version number or to execute parts of the upgrade process without permission. As upgrading in the user interface is deprecated, this functionality is no longer required. Patches Upgrade to 4.4.13 or 5.1.1 or later. Workarounds None. For more information If you have any questions or comments about this advisory: Email us at security@mautic.org

    Recommended action: Upgrade to 5.1.1 or 4.4.13 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →