Skip to content

← Actionable
Medium, CVSS 5.1

Mautic vulnerable to XSS in contact/company tracking (no authentication)

CVE-2024-47050GHSA-73gr-32wg-qhh7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core-lib 5.1.1, 4.4.13; mautic/core 5.1.1, 4.4.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mautic/core-lib

    Affected
    >= 2.6.0, < 4.4.13>= 5.0.0-alpha, < 5.1.1
    Fixed in
    4.4.13, 5.1.1
  • Packagist mautic/core

    Affected
    >= 2.6.0, < 4.4.13>= 5.0.0-alpha, < 5.1.1
    Fixed in
    4.4.13, 5.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2024-47050: 0.31% estimated exploitation activity in the next 30 days; percentile 23.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Prior to this patch being applied, Mautic's tracking was vulnerable to Cross-Site Scripting through the Page URL variable. Patches Please update to 4.4.13 or 5.1.1 or later. Workarounds None References https://owasp.org/www-project-top-ten/2017/A72017-Cross-SiteScripting(XSS) https://owasp.org/www-project-web-security-testing-guide/latest/4-WebApplicationSecurityTesting/07-InputValidationTesting/02-TestingforStoredCrossSiteScripting If you have any questions or comments about this advisory: Email us at security@mautic.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-73gr-32wg-qhh7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47050

Advisory: Mautic vulnerable to XSS in contact/company tracking (no authentication)
IDs: CVE-2024-47050, GHSA-73gr-32wg-qhh7
Record: https://patchnext.com/advisories/cve-2024-47050 (revision 1, source checked 26 Oct 2026, 14:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mautic/core-lib 5.1.1, 4.4.13; mautic/core 5.1.1, 4.4.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mautic/core-lib: affected >= 2.6.0, < 4.4.13; >= 5.0.0-alpha, < 5.1.1; fixed in 4.4.13, 5.1.1
- Packagist mautic/core: affected >= 2.6.0, < 4.4.13; >= 5.0.0-alpha, < 5.1.1; fixed in 4.4.13, 5.1.1

## Suggested inspection (read-only)
- Packagist mautic/core-lib: check the installed version with your package manager.
- Packagist mautic/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mautic/core-lib, mautic/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-73gr-32wg-qhh7 (GitHub-reviewed advisory GHSA-73gr-32wg-qhh7 lists affected ranges: Packagist mautic/core >=2.6.0 =5.0.0-alpha =2.6.0 =5.0.0-alpha <5.1.1)

Commands are suggestions: review each one before running it.

Loading voting…