High, CVSS 7.2PackagistPublished
Magento 2 Community Edition RCE Vulnerability
CVE-2019-8114 · GHSA-crv7-r357-gw3w
- Affected
- Packagist magento/project-community-edition < 1.9.4.3
- Fixed in
- 1.9.4.3· Vendor fix available
- Issue
- A remote code execution vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to import features can execute arbitrary code via crafted configuration archive file upload. As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
Recommended action: Upgrade to 1.9.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.