Magento 2 Community Edition RCE Vulnerability
CVE-2019-8114GHSA-crv7-r357-gw3w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (magento/project-community-edition 1.9.4.3; magento/community-edition 2.3.2-p2, 2.2.10, 1.9.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist magento/project-community-edition
- Affected
- < 1.9.4.3
- Fixed in
- 1.9.4.3
Packagist magento/community-edition
- Affected
- < 1.9.4.3>= 2.2.0, < 2.2.10>= 2.3.0, < 2.3.2-p2
- Fixed in
- 1.9.4.3, 2.3.2-p2, 2.2.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-crv7-r357-gw3w lists affected ranges: Packagist magento/community-edition >=0 =2.2.0 =2.3.0 =0 <1.9.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-8114: 1.85% estimated exploitation activity in the next 30 days; percentile 79.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A remote code execution vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to import features can execute arbitrary code via crafted configuration archive file upload. As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-crv7-r357-gw3w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-8114 Advisory: Magento 2 Community Edition RCE Vulnerability IDs: CVE-2019-8114, GHSA-crv7-r357-gw3w Record: https://patchnext.com/advisories/cve-2019-8114 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: magento/project-community-edition 1.9.4.3; magento/community-edition 2.3.2-p2, 2.2.10, 1.9.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist magento/project-community-edition: affected < 1.9.4.3; fixed in 1.9.4.3 - Packagist magento/community-edition: affected < 1.9.4.3; >= 2.2.0, < 2.2.10; >= 2.3.0, < 2.3.2-p2; fixed in 1.9.4.3, 2.3.2-p2, 2.2.10 ## Suggested inspection (read-only) - Packagist magento/project-community-edition: check the installed version with your package manager. - Packagist magento/community-edition: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magento/project-community-edition, magento/community-edition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-crv7-r357-gw3w (GitHub-reviewed advisory GHSA-crv7-r357-gw3w lists affected ranges: Packagist magento/community-edition >=0 =2.2.0 =2.3.0 =0 <1.9.4.3) Commands are suggestions: review each one before running it.
Loading voting…