Skip to content

← Public intelligence

Packagist package

magento/core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

8 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PackagistPublished

    Magento defense-in-depth security mitigation vulnerability

    CVE-2020-9591 · GHSA-w7rh-9w5v-rwqj

    Affected
    • Packagist magento/core < 1.9.4.5
    Fixed in
    1.9.4.5· Partial vendor fix
    Issue
    Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a defense-in-depth security mitigation vulnerability. Successful exploitation could lead to unauthorized access to admin panel.

    Recommended action: Upgrade to 1.9.4.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8PackagistPublished

    Magento Security mitigation bypass vulnerability

    CVE-2020-9579 · GHSA-vrp3-wc28-qg2h

    Affected
    • Packagist magento/core < 1.9.4.5
    Fixed in
    1.9.4.5· Partial vendor fix
    Issue
    Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a security mitigation bypass vulnerability. Successful exploitation could lead to arbitrary code execution.

    Recommended action: Upgrade to 1.9.4.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5PackagistPublished

    Magento sql injection vulnerability

    CVE-2020-3719 · GHSA-rr59-pjwj-6grj

    Affected
    • Packagist magento/core < 1.9.4.4
    Fixed in
    1.9.4.4· Vendor fix available
    Issue
    Magento versions 2.3.3 and earlier, 2.2.10 and earlier, 1.14.4.3 and earlier, and 1.9.4.3 and earlier have an sql injection vulnerability. Successful exploitation could lead to sensitive information disclosure.

    Recommended action: Upgrade to 1.9.4.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.1PackagistPublished

    Magento stored cross-site scripting vulnerability

    CVE-2020-3715 · GHSA-mgg3-v948-2vgr

    Affected
    • Packagist magento/core < 1.9.4.4
    Fixed in
    1.9.4.4· Vendor fix available
    Issue
    Magento versions 2.3.3 and earlier, 2.2.10 and earlier, 1.14.4.3 and earlier, and 1.9.4.3 and earlier have a stored cross-site scripting vulnerability. Successful exploitation could lead to sensitive information disclosure.

    Recommended action: Upgrade to 1.9.4.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 8.8PackagistPublished

    Magento arbitrary PHP code execution via the productData parameter

    CVE-2015-6497 · GHSA-j4fq-3fm7-wh5v

    Affected
    • Packagist magento/core < 1.9.2.1
    Fixed in
    1.9.2.1· Vendor fix available
    Issue
    The create function in app/code/core/Mage/Catalog/Model/Product/Api/V2.php in Magento Community Edition (CE) before 1.9.2.1 and Enterprise Edition (EE) before 1.14.2.1, when used with PHP before 5.4.24 or 5.5.8, allows remote authenticated users to execute arbitrary PHP code via the productData parameter to index.php/api/v2soap.

    Recommended action: Upgrade to 1.9.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 7.2PackagistPublished

    Magento Remote code execution through catalog attribute sets

    CVE-2019-8231 · GHSA-qpc8-m2xm-9w75

    Affected
    • Packagist magento/core < 1.9.4.3
    Fixed in
    1.9.4.3· Vendor fix available
    Issue
    In Magento Open Source prior to 1.9.4.3, and Magento Commerce prior to 1.14.4.3, an authenticated user with administrative privileges for editing attribute sets can execute arbitrary code through custom layout modification.

    Recommended action: Upgrade to 1.9.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Medium, CVSS 4.8PackagistPublished

    Magento XSS Vulnerability

    CVE-2019-8227 · GHSA-j49x-jjmj-9fqj

    Affected
    • Packagist magento/core < 1.9.4.3
    Fixed in
    1.9.4.3· Vendor fix available
    Issue
    In Magento prior to 1.9.4.3 and Magento prior to 1.14.4.3, an authenticated user with limited administrative privileges can inject arbitrary JavaScript code via import / export functionality when creating profile action XML.

    Recommended action: Upgrade to 1.9.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. High, CVSS 7.2PackagistPublished

    Magento Remote code execution through support/output path modification

    CVE-2019-8230 · GHSA-qp43-2vhf-cj8g

    Affected
    • Packagist magento/core < 1.9.4.3
    Fixed in
    1.9.4.3· Vendor fix available
    Issue
    In Magento Open Source prior to 1.9.4.3, and Magento Commerce prior to 1.14.4.3, an authenticated user with administrative privileges to edit configuration settings can execute arbitrary code through a crafted support/output path.

    Recommended action: Upgrade to 1.9.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →