Magento defense-in-depth security mitigation vulnerability
CVE-2020-9591GHSA-w7rh-9w5v-rwqj
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist magento/core
- Affected
- < 1.9.4.5
- Fixed in
- 1.9.4.5
Packagist magento/community-edition
- Affected
- >= 2.3.0, < 2.3.4-p2<= 2.2.11
- Fixed in
- 2.3.4-p2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w7rh-9w5v-rwqj lists affected ranges: Packagist magento/community-edition >=2.3.0 =0 =0 <1.9.4.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2020-9591: 3.43% estimated exploitation activity in the next 30 days; percentile 88.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a defense-in-depth security mitigation vulnerability. Successful exploitation could lead to unauthorized access to admin panel.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w7rh-9w5v-rwqj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-9591 Advisory: Magento defense-in-depth security mitigation vulnerability IDs: CVE-2020-9591, GHSA-w7rh-9w5v-rwqj Record: https://patchnext.com/advisories/cve-2020-9591 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: magento/core 1.9.4.5; magento/community-edition 2.3.4-p2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist magento/core: affected < 1.9.4.5; fixed in 1.9.4.5 - Packagist magento/community-edition: affected >= 2.3.0, < 2.3.4-p2; <= 2.2.11; fixed in 2.3.4-p2 ## Suggested inspection (read-only) - Packagist magento/core: check the installed version with your package manager. - Packagist magento/community-edition: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magento/core, magento/community-edition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w7rh-9w5v-rwqj (GitHub-reviewed advisory GHSA-w7rh-9w5v-rwqj lists affected ranges: Packagist magento/community-edition >=2.3.0 =0 =0 <1.9.4.5) Commands are suggestions: review each one before running it.
Loading voting…