Critical, CVSS 9.8PackagistPublished
SQL Injection in liftkit/database
CVE-2016-15020 · GHSA-8hcf-2m4v-f2rq
- Affected
- Packagist liftkit/database < 2.13.2
- Fixed in
- 2.13.2· Vendor fix available
- Issue
- A vulnerability was found in liftkit database up to 2.13.1. It has been classified as critical. This affects the function processOrderBy of the file src/Query/Query.php. The manipulation leads to sql injection. Upgrading to version 2.13.2 is able to address this issue. The name of the patch is 42ec8f2b22e0b0b98fb5b4444ed451c1b21d125a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-218391.
Recommended action: Upgrade to 2.13.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.