SQL Injection in liftkit/database
CVE-2016-15020GHSA-8hcf-2m4v-f2rq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (liftkit/database 2.13.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist liftkit/database
- Affected
- < 2.13.2
- Fixed in
- 2.13.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8hcf-2m4v-f2rq lists affected ranges: Packagist liftkit/database >=0 <2.13.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2016-15020: 0.70% estimated exploitation activity in the next 30 days; percentile 53.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was found in liftkit database up to 2.13.1. It has been classified as critical. This affects the function processOrderBy of the file src/Query/Query.php. The manipulation leads to sql injection. Upgrading to version 2.13.2 is able to address this issue. The name of the patch is 42ec8f2b22e0b0b98fb5b4444ed451c1b21d125a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-218391.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8hcf-2m4v-f2rq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-15020 Advisory: SQL Injection in liftkit/database IDs: CVE-2016-15020, GHSA-8hcf-2m4v-f2rq Record: https://patchnext.com/advisories/cve-2016-15020 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: liftkit/database 2.13.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist liftkit/database: affected < 2.13.2; fixed in 2.13.2 ## Suggested inspection (read-only) - Packagist liftkit/database: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on liftkit/database. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8hcf-2m4v-f2rq (GitHub-reviewed advisory GHSA-8hcf-2m4v-f2rq lists affected ranges: Packagist liftkit/database >=0 <2.13.2) Commands are suggestions: review each one before running it.
Loading voting…