Skip to content

← Public intelligence

Packagist package

kreait/firebase-php

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1PackagistPublished

    Jerome Gamez Firebase Admin SDK for PHP Incorrect Access Control vulnerability

    CVE-2018-1000025 · GHSA-4gjj-r7w8-42cq

    Affected
    • Packagist kreait/firebase-php >= 3.2.0, < 3.8.1
    Fixed in
    3.8.1· Vendor fix available
    Issue
    Jerome Gamez Firebase Admin SDK for PHP version from 3.2.0 to 3.8.0 contains a Incorrect Access Control vulnerability in src/Firebase/Auth/IdTokenVerifier.php does not verify for token signature that can result in JWT with any email address and user ID could be forged from an actual token, or from thin air. This attack appear to be exploitable via Attacker would only need to know email address of the victim on most cases.. This vulnerability appears to have been fixed in 3.8.1.

    Recommended action: Upgrade to 3.8.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →