Skip to content

← Actionable
High, CVSS 8.1

Jerome Gamez Firebase Admin SDK for PHP Incorrect Access Control vulnerability

CVE-2018-1000025GHSA-4gjj-r7w8-42cq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kreait/firebase-php 3.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-1000025: 1.31% estimated exploitation activity in the next 30 days; percentile 70.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jerome Gamez Firebase Admin SDK for PHP version from 3.2.0 to 3.8.0 contains a Incorrect Access Control vulnerability in src/Firebase/Auth/IdTokenVerifier.php does not verify for token signature that can result in JWT with any email address and user ID could be forged from an actual token, or from thin air. This attack appear to be exploitable via Attacker would only need to know email address of the victim on most cases.. This vulnerability appears to have been fixed in 3.8.1.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4gjj-r7w8-42cq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1000025

Advisory: Jerome Gamez Firebase Admin SDK for PHP Incorrect Access Control vulnerability
IDs: CVE-2018-1000025, GHSA-4gjj-r7w8-42cq
Record: https://patchnext.com/advisories/cve-2018-1000025 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kreait/firebase-php 3.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist kreait/firebase-php: affected >= 3.2.0, < 3.8.1; fixed in 3.8.1

## Suggested inspection (read-only)
- Packagist kreait/firebase-php: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kreait/firebase-php.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4gjj-r7w8-42cq (GitHub-reviewed advisory GHSA-4gjj-r7w8-42cq lists affected ranges: Packagist kreait/firebase-php >=3.2.0 <3.8.1)

Commands are suggestions: review each one before running it.

Loading voting…