Skip to content

← Public intelligence

Packagist package

joomla/filter

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.8PackagistPublished

    Joomla! CMS vulnerable to XSS via the input filter

    CVE-2025-54476 · GHSA-fm22-g2q9-j3pw

    Affected
    • Packagist joomla/filter >= 4.0.0, <= 4.0.0; >= 3.0.0, < 3.0.5; < 2.0.6
    Fixed in
    2.0.63.0.54.0.1· Vendor fix available
    Issue
    Improper handling of input could lead to a cross-site scripting (XSS) vector in the checkAttribute method of the input filter framework class.

    Recommended action: Upgrade to 4.0.1, 3.0.5 or 2.0.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1PackagistPublished

    Cross-site Scripting (XSS) within joomla/filter class

    CVE-2022-23800 · GHSA-qcv6-h33g-hvrc

    Affected
    • Packagist joomla/filter < 1.4.4; >= 2.0.0, < 2.0.1
    Fixed in
    2.0.11.4.4· Vendor fix available
    Issue
    An issue was discovered in Joomla! 4.0.0 through 4.1.0. Inadequate content filtering leads to XSS vulnerabilities in various components.

    Recommended action: Upgrade to 2.0.1 or 1.4.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →