Joomla! CMS vulnerable to XSS via the input filter
CVE-2025-54476GHSA-fm22-g2q9-j3pw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (joomla/filter 4.0.1, 3.0.5, 2.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist joomla/filter
- Affected
- >= 4.0.0, <= 4.0.0>= 3.0.0, < 3.0.5< 2.0.6
- Fixed in
- 2.0.6, 3.0.5, 4.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fm22-g2q9-j3pw lists affected ranges: Packagist joomla/filter >=4.0.0 =3.0.0 =0 <2.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-54476: 0.31% estimated exploitation activity in the next 30 days; percentile 24.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper handling of input could lead to a cross-site scripting (XSS) vector in the checkAttribute method of the input filter framework class.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fm22-g2q9-j3pw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54476 Advisory: Joomla! CMS vulnerable to XSS via the input filter IDs: CVE-2025-54476, GHSA-fm22-g2q9-j3pw Record: https://patchnext.com/advisories/cve-2025-54476 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: joomla/filter 4.0.1, 3.0.5, 2.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist joomla/filter: affected >= 4.0.0, <= 4.0.0; >= 3.0.0, < 3.0.5; < 2.0.6; fixed in 2.0.6, 3.0.5, 4.0.1 ## Suggested inspection (read-only) - Packagist joomla/filter: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on joomla/filter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fm22-g2q9-j3pw (GitHub-reviewed advisory GHSA-fm22-g2q9-j3pw lists affected ranges: Packagist joomla/filter >=4.0.0 =3.0.0 =0 <2.0.6) Commands are suggestions: review each one before running it.
Loading voting…