Skip to content

← Public intelligence

Packagist package

james-heinrich/getid3

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedPackagistPublished

    getID3 is vulnerable to XML External Entity (XXE)

    CVE-2014-2053 · GHSA-5v43-55m5-qr8f

    Affected
    • Packagist james-heinrich/getid3 < 1.9.9
    Fixed in
    1.9.9· Vendor fix available
    Issue
    getID3() before 1.9.9, as used in ownCloud Server before 5.0.15 and 6.0.x before 6.0.2, allows remote attackers to read arbitrary files, cause a denial of service, or possibly have other impact via an XML External Entity (XXE) attack.

    Recommended action: Upgrade to 1.9.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1PackagistPublished

    Cross-site scripting in demos/demo.mysqli.php in getID3

    CVE-2021-40926 · GHSA-x2gw-85w6-fjjw

    Affected
    • Packagist james-heinrich/getid3 >= 1.0.0, < 1.9.21
    Fixed in
    1.9.21· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in demos/demo.mysqli.php in getID3 1.X and v2.0.0-beta allows remote attackers to inject arbitrary web script or HTML via the showtagfiles parameter.

    Recommended action: Upgrade to 1.9.21 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →