getID3 is vulnerable to XML External Entity (XXE)
CVE-2014-2053GHSA-5v43-55m5-qr8f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (james-heinrich/getid3 1.9.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist james-heinrich/getid3
- Affected
- < 1.9.9
- Fixed in
- 1.9.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5v43-55m5-qr8f lists affected ranges: Packagist james-heinrich/getid3 >=0 <1.9.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-2053: 4.68% estimated exploitation activity in the next 30 days; percentile 91.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
getID3() before 1.9.9, as used in ownCloud Server before 5.0.15 and 6.0.x before 6.0.2, allows remote attackers to read arbitrary files, cause a denial of service, or possibly have other impact via an XML External Entity (XXE) attack.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5v43-55m5-qr8f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-2053 Advisory: getID3 is vulnerable to XML External Entity (XXE) IDs: CVE-2014-2053, GHSA-5v43-55m5-qr8f Record: https://patchnext.com/advisories/cve-2014-2053 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: james-heinrich/getid3 1.9.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist james-heinrich/getid3: affected < 1.9.9; fixed in 1.9.9 ## Suggested inspection (read-only) - Packagist james-heinrich/getid3: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on james-heinrich/getid3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5v43-55m5-qr8f (GitHub-reviewed advisory GHSA-5v43-55m5-qr8f lists affected ranges: Packagist james-heinrich/getid3 >=0 <1.9.9) Commands are suggestions: review each one before running it.
Loading voting…