Skip to content

← Public intelligence

Packagist package

illuminate/view

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.7PackagistPublished

    Laravel Cross-site Scripting vulnerability in blade templating

    GHSA-297g-xg4h-7w4c

    Affected
    • Packagist illuminate/view >= 7.0.0, < 7.1.2
    Fixed in
    7.1.2· Vendor fix available
    Issue
    Laravel is prone to a Cross-site Scripting vulnerability in blade templating.

    Recommended action: Upgrade to 7.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1PackagistPublished

    Laravel Framework XSS in Blade templating engine

    CVE-2021-43808 · GHSA-66hf-2p6w-jqfw

    Affected
    • Packagist illuminate/view < 6.20.42; >= 7.0.0, < 7.30.6; >= 8.0.0, < 8.75.0
    Fixed in
    8.75.06.20.427.30.6· Vendor fix available
    Issue
    A security researcher has disclosed a possible XSS vulnerability in the Blade templating engine. Given the following two Blade templates: resources/views/parent.blade.php: resources/views/child.blade.php: And a route like the following: The broken HTML element may be clicked and the user is taken to another location in their browser due to XSS. This is due to the user being able to guess the parent placeholder SHA-1 hash by trying common names of sections. If the parent template contains an exploitable HTML structure an XSS vulnerability can be exposed. This vulnerability has been patched by determining the parent placeholder at runtime and using a random hash that is unique to each request.

    Recommended action: Upgrade to 8.75.0, 7.30.6 or 6.20.42 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →