Laravel Framework XSS in Blade templating engine
CVE-2021-43808GHSA-66hf-2p6w-jqfw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (laravel/framework 8.75.0, 7.30.6, 6.20.42; illuminate/view 8.75.0, 7.30.6, 6.20.42), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist laravel/framework
- Affected
- < 6.20.42>= 7.0.0, < 7.30.6>= 8.0.0, < 8.75.0
- Fixed in
- 8.75.0, 6.20.42, 7.30.6
Packagist illuminate/view
- Affected
- < 6.20.42>= 7.0.0, < 7.30.6>= 8.0.0, < 8.75.0
- Fixed in
- 8.75.0, 6.20.42, 7.30.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-66hf-2p6w-jqfw lists affected ranges: Packagist laravel/framework >=0 =7.0.0 =8.0.0 =0 =7.0.0 =8.0.0 <8.75.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-43808: 0.83% estimated exploitation activity in the next 30 days; percentile 57.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A security researcher has disclosed a possible XSS vulnerability in the Blade templating engine. Given the following two Blade templates: resources/views/parent.blade.php: resources/views/child.blade.php: And a route like the following: The broken HTML element may be clicked and the user is taken to another location in their browser due to XSS. This is due to the user being able to guess the parent placeholder SHA-1 hash by trying common names of sections. If the parent template contains an exploitable HTML structure an XSS vulnerability can be exposed. This vulnerability has been patched by determining the parent placeholder at runtime and using a random hash that is unique to each request.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-66hf-2p6w-jqfw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43808 Advisory: Laravel Framework XSS in Blade templating engine IDs: CVE-2021-43808, GHSA-66hf-2p6w-jqfw Record: https://patchnext.com/advisories/cve-2021-43808 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: laravel/framework 8.75.0, 7.30.6, 6.20.42; illuminate/view 8.75.0, 7.30.6, 6.20.42. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist laravel/framework: affected < 6.20.42; >= 7.0.0, < 7.30.6; >= 8.0.0, < 8.75.0; fixed in 8.75.0, 6.20.42, 7.30.6 - Packagist illuminate/view: affected < 6.20.42; >= 7.0.0, < 7.30.6; >= 8.0.0, < 8.75.0; fixed in 8.75.0, 6.20.42, 7.30.6 ## Suggested inspection (read-only) - Packagist laravel/framework: check the installed version with your package manager. - Packagist illuminate/view: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on laravel/framework, illuminate/view. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-66hf-2p6w-jqfw (GitHub-reviewed advisory GHSA-66hf-2p6w-jqfw lists affected ranges: Packagist laravel/framework >=0 =7.0.0 =8.0.0 =0 =7.0.0 =8.0.0 <8.75.0) Commands are suggestions: review each one before running it.
Loading voting…